เจอปัญหา GPG Error (ลายเซ็นใช้ไม่ได้) ครับ

AttachmentSize
Image icon GPGError.png22.83 KB
Image icon apt-key.png67.12 KB

ผมเพิ่งใช้ Debian 5.0 ครับ เพิ่งจะติดตั้งเสร็จเสร็จ
จากนั้นใช้ Synaptic เพื่อติดตั้งโปรแกรมเพิ่มแล้วพบปัญหา GPG Error ดังรูปที่แนบครับ

เคยค้นหาทางแก้ไขจาก Internet มีคนแนะนำให้ update key โดยใช้ apt-key
ก็ลองดู ก็ได้ผลดังรูปที่แนบอีกรูปหนึ่งครับ
แต่ปัญหา GPG Error ก็ไม่หายไป

คนอื่น ๆ มีปัญหาเหมือนกันบ้างไหมครับ แก้ไขอย่างไรครับ

ลอง upgrade แพกเกจ debian-archive-keyring แค่แพกเกจเดียวก่อนนะครับ โดยข้าม warning นี้ไปก่อน มันจะไปดึง key ล่าสุดมาลงให้

ส่วนคำสั่ง apt-key update จะเป็นการ update key จาก debian-archive-keyring ที่ติดตั้งไว้ครับ โดยปกติหลังติดตั้ง debian-archive-keyring แล้ว สคริปต์ postinst มันก็จะเรียกให้อยู่แล้วครับ เรียกใหม่ก็ยังคงได้คีย์เดิมนั่นแหละครับ

ทำตามที่คุณเทพแนะนำแล้ว
และได้ผลดีคือไม่มี GPG Error แล้วครับ
ขอบคุณครับ

Creative Commons License ลิขสิทธิ์ของบทความเป็นของเจ้าของบทความแต่ละชิ้น
ผลงานนี้ ใช้สัญญาอนุญาตของครีเอทีฟคอมมอนส์แบบ แสดงที่มา-อนุญาตแบบเดียวกัน 3.0 ที่ยังไม่ได้ปรับแก้