Debian GNU/Linux 5.0 "Lenny" ออกแล้ว

Debian GNU/Linux 5.0 "Lenny" ออกแล้ว

สำหรับรุ่นนี้ รองรับอย่างเป็นทางการ 12 สถาปัตยกรรม เพิ่มการรองรับอุปกรณ์เก็บข้อมูลใหม่ ๆ และรองรับเน็ตบุ๊กหลายรุ่น รวมถึง Eee PC และ อุปกรณ์ฝังตัว ที่ใช้ ARM โดยในรุ่น Lenny นี้ ได้พอร์ตไปยัง ARM EABI หรือ "armel" และเตรียมยกเลิกการใช้ "arm" port

ซอฟต์แวร์ที่มากับ Lenny:

  • KDE 3.5.10
  • GNOME 2.22.2
  • Xfce 4.4.2
  • LXDE 0.3.2.1
  • GNUstep 7.3
  • X.Org 7.3
  • OpenOffice.org 2.4.1
  • GIMP 2.4.7
  • Iceweasel (unbranded Firefox) 3.0.6
  • Icedove (unbranded Thunderbird) 2.0.0.19
  • PostgreSQL 8.3.6
  • MySQL 5.0.51a
  • GCC 4.3.2
  • Linux 2.6.26
  • Apache 2.2.9
  • Samba 3.2.5
  • Python 2.5.2, 2.4.6
  • Perl 5.10.0
  • PHP 5.2.6

Debian GNU/Linux สามารถติดตั้งได้ทั้งจาก DVD, CD, USB stick, แผ่นฟล็อปปี้ หรือจากเครือข่าย โดยถ้าติดตั้งแบบเดสก์ท็อป GNOME จะเป็นเดสก์ท็อปปริยายซึ่งติดตั้งได้โดยใช้ซีดีแผ่นแรกแผ่นเดียว แต่ Lenny ก็เป็นรุ่นแรกที่มี CD image แบบอื่นเพิ่มเติมให้ด้วย โดยสามารถเลือก image ที่ลง KDE, Xfce หรือ LXDE เป็นเดสก์ท็อปปริยายก็ได้ รวมทั้งเป็นรุ่นแรกที่มีแผ่นติดตั้งแบบ Blu-ray ด้วย โดยใช้ Blu-ray เพียงแผ่นเดียวสำหรับสถาปัตยกรรมหนึ่ง ๆ

นอกจากนี้ Lenny ก็ยังเป็นรุ่นแรกที่มี Live CD อย่างเป็นทางการจาก Debian ด้วย (หลังจากที่มีแต่จาก derivative distro เช่น Knoppix, Sidux มานาน -- ดูข่าวเก่า)

ดาวน์โหลดแผ่นติดตั้ง Debian GNU/Linux ได้จาก แหล่งซีดี หรือสั่งซื้อจาก ผู้จัดจำหน่าย ได้ครับ

รายละเอียดของ Lenny ทั้งหมด อ่านได้จาก บันทึกประจำรุ่น (แปลไทยไม่ทันครับ)

ที่มา: Debian News

Comments

สุดยอดจริงๆ รอมานานครับ

โหลดมาทำ mirror แล้วครับ เฉพาะตัว netinst นะ
http://mirror.thaismartnetwork.com/debian/lenny/

The Best OS of The World
---------------
eak Blog iBlog

ใครใช้ repo ของที่ไหนบ้างอ่ะครับ แนะนำต่อทีครับ

ลองดูรายชื่อ mirror ในไทยจากหน้า Debian Mirrors ของเราก่อนนะครับ

เพิ่มเติมข้อมูล: ที่ TuxRadar มีรายละเอียดเพิ่มเติมเกี่ยวกับสิ่งใหม่ใน Lenny, วิธี upgrade, บทวิจารณ์ พร้อมบทสัมภาษณ์ DPL เกี่ยวกับอุปสรรคต่าง ๆ กว่าจะเข็น Lenny ออกมาได้

จากบทวิจารณ์ของผู้เขียน Lenny ถือเป็นรุ่นที่ประสบความสำเร็จค่อนข้างสูง เมื่อเทียบในแง่ของระยะเวลาที่ใช้ในการพัฒนา กับสิ่งใหม่ ๆ ที่เกิดขึ้นในรุ่นนี้

Mirror CD เสร็จแล้วนะครับ ที่เดิม....

http://ftp.linux.in.th/mirror/debian-cd/

ครบเลย ขอบคุณครับ

ขอรบกวนถามครับว่า ใน Lenny มีอะไรที่คล้ายๆกันกับ language support ของ ubuntu หรือปล่าวครับ
เพราะผมต้องใช้หลายภาษา และคิดว่าของ ubuntu มันสะดวกใช้ดีมาก แต่ถ้า lenny มีผมก็จะเปลี่ยนมาใช้ lenny ทันทีเลยครับ

ตามปกติ ถ้าจะลง language support บน debian ผมจะใช้ aptitude แล้วเลือกที่หมวด Tasks > Localization นะครับ ในนั้น แต่ละ task จะมีรายชื่อแพกเกจของแต่ละภาษาให้เลือก อยากได้ภาษาอะไรก็เลือกเอาโลด

ลงแล้วครับ ไม่ค่อยเปลี่ยนไปจาก etch นักน่ะ เท่าที่ newbie อย่างผมมองเห็น ปัญหาคือทำยังไงให้อ่านไทยได้
ผมติดปัญหาอีกอย่างคือ ลง vmware server ไม่ได้ครับ หลังจากที่อ่าน License agreement จบก็ติดตรงนี้ครับ

None of the pre-built vmmon modules for Vmware Server is situable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)?[yes] ---> [enter]

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

Your kernel was built with "gcc" version "4.1.3", while you are trying to use
"/usr/bin/gcc" version "4.3.2". This configuration is not recommended and
VMware Server may crash if you'll continue. Please try to use exactly same
compiler as one used for building your kernel. Do you want to go with compiler
"/usr/bin/gcc" version "4.3.2" anyway? [no]

ถ้าผมตอบ [y] ก็จะเป็น

What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.6.26-1-686/build/include] ---> [enter]

Extracting the source of the vmmon modules.

Building the vmmon module.

Using 2.6.x kernel build system.
make: Entering directory '/tmp/vmware-config0/vmmon-only'
make -C /lib/modules/2.6.26-1-686/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory '/usr/src/linux-headers-2.6.26-1-686'
/tmp/vmware-config0/vmmon-only/Makefile:106: *** Inappropriate build environment: you want to use gcc
version 4.3.2 while kernel attempts to use gcc version 4.1.3
/tmp/vmware-config0/vmmon-only/Makefile:108: *** For proper build you'll have to replace gcc-4.1 with
symbolic link to /usr/bin/gcc. Stop
make[1]: *** [_module_/tmp/vmware-config0/vmmon-only] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-2.6.26-1-686'
make: *** [vmmon.ko] Error 2
make[1]: Leaving directory '/tmp/vmware-config0/vmmon-only'
unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/go/unsup-linux-products" and
"http://www.vmware.com/go/unsup-linux-tools"

Execution aborted.

lenny:~\vmware-server-distrib#

ผมทำ ลิงค์ ไม่เป็นครับ ต้องทำไงครับ

ลินุกซ์ไทย จงเจริญ

สั่งอย่างนี้นะครับ

# ln -sf gcc-4.1 /usr/bin/gcc

มันจะสร้างลิงก์ /usr/bin/gcc ไปยัง gcc-4.1 ทับแทนที่ gcc-4.3 เดิม

ขอบคุณครับ ได้ผลยังไงจะกลับมาแจ้งให้ทราบครับ

ลินุกซ์ไทย จงเจริญ

พี่ครับ
ผมไม่ใช่สายคอมพิวเตอร์โดยตรงแต่สนใจDebian (พอรู้จัก command line บ้าง ) สมควรที่จะลองเล่น Debian ได้หรือไม่ครับ
ผมเป็นวิศวกรโยธาครับ คืออยากจะลองเขียน application บน Linux ครับ

ผมเพิ่งอัพเกรดจาก etch เป็น lenny เห็นการเปลี่ยนแปลงค่อนข้างเยอะ ไอ้ที่ลงไม่ได้ ก็ลงได้ ไอ้ที่ใช้ไม่ได้ ก็ใช้ได้ แจ่มเลยครับ

My Drupal Sites.
ลงประกาศฟรี ละคร

Creative Commons License ลิขสิทธิ์ของบทความเป็นของเจ้าของบทความแต่ละชิ้น
ผลงานนี้ ใช้สัญญาอนุญาตของครีเอทีฟคอมมอนส์แบบ แสดงที่มา-อนุญาตแบบเดียวกัน 3.0 ที่ยังไม่ได้ปรับแก้